為增加系統安全性,谷歌將禁止在Android 14中安裝過時應用

雖然Android 13的正式版剛推出不久,很大一部分手機還沒用上,但是谷歌已經在計劃Android 14的事情了。援引9to5Google的消息稱,Android 14會實現更嚴格的應用安裝限制,以保證用戶手機的安全。

這些變化是從AOSP的代碼更改(現已被隱藏)中發現的,Android 14會完全阻止安裝API級別過低的App,這不僅適用於Play商店里的應用,甚至對於第三方商店和Apk安裝包來說也是如此。這有利於防止一些惡意軟體利用低級別API繞過系統保護措施的行為,提高了手機和平板等設備的安全性。

為增加系統安全性,谷歌將禁止在Android 14中安裝過時應用

當然,谷歌一開始並不會把這個限製版本設置得太高,它只會阻止特定的舊版本應用,而隨著時間的推移,限制等級將逐步提高到Android 6.0,API級別為23。作為參照,目前主流的Android 12的API級別為31,如果應用想要登錄Play商店,則要求其API級別為29(Android 10)及以上。

不過谷歌並未說明這個限制等級的提升機制是如何運作的,很有可能這個功能的開關仍然是由設備廠商自行決定。另外,即使開啟了這個限制,谷歌還是提供了ADB命令行的方式用於安裝那些受限的過時應用,畢竟一般能熟練操作命令行的基本都是富有經驗的用戶或者開發者,他們誤裝惡意軟體的機率太低了。

來源:超能網